Search-form

9.15.2011

Configuring OSPF for Multiple Areas and Frame Relay Nonbroadcast

For example, OSPF can be deployed in a hierarchical structure in which the network is divided into
OSPF zones called areas. In addition, OSPF operates differently on different types of interfaces.
This lab focuses on a multiple-area OSPF network, with Frame Relay (that is, nonbroadcast) interfaces.
Ethernet (that is, broadcast) interfaces are also addressed.

An OSPF troubleshooting scenario, integrated into this lab, explores the need for virtual links on
some OSPF networks. The objectives of this lab are as follows:
■ Reviewing OSPF network types
■ Configuring OSPF
■ Verifying OSPF neighbors and router IDs
■ Describing the need for virtual links
■ Configuring virtual links
■ Verifying end-to-end connectivity

Step 1: Configure and Verify Basic OSPF Connectivity—Initial Configurations

Initial Configuration for R1
hostname R1
!
interface Loopback0
ip address 1.1.1.1 255.255.255.255
!
interface Ethernet0
ip address 10.1.2.1 255.255.255.0
!
interface Serial0
ip address 10.1.1.1 255.255.255.0
encapsulation frame-relay IETF
frame-relay map ip 10.1.1.2 100 broadcast

Initial Configuration for R2
hostname R2
!
interface Loopback0
ip address 2.2.2.2 255.255.255.255
!
interface Ethernet0/0
ip address 172.16.1.2 255.255.255.0
half-duplex
!
interface Serial0/0
ip address 10.1.1.2 255.255.255.0
encapsulation frame-relay IETF
frame-relay map ip 10.1.1.1 200 broadcast

Initial Configuration for R3
hostname R3
!
interface Loopback0
ip address 3.3.3.3 255.255.255.255
!
interface FastEthernet0/0
ip address 172.16.1.3 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 192.168.1.3 255.255.255.0
duplex auto
speed auto

Initial Configuration for R4
hostname R4
!
ip routing
!
interface Loopback0
ip address 4.4.4.4 255.255.255.255
!
interface GigabitEthernet0/1
no switchport
ip address 192.168.1.4 255.255.255.0

Configuration for FRSW
hostname FRSW
!
frame-relay switching
!
interface Serial0
encapsulation frame-relay IETF
clock rate 2000000
frame-relay lmi-type cisco
frame-relay intf-type dce
frame-relay route 100 interface Serial1 200
!
interface Serial1
no ip address
encapsulation frame-relay IETF
clock rate 2000000
frame-relay lmi-type cisco
frame-relay intf-type dce
frame-relay route 200 interface Serial0 100

Step 1: Configure and Verify Basic OSPF Connectivity— Ending Configurations

A portion of the topology used in this lab contains a Frame Relay network, which defaults to a nonbroadcast OSPF network type. Therefore, commands are added to establish an OSPF adjacency
across the Frame Relay network and to influence which of the routers connected to the Frame
Relay network is elected as the DR.

A DR reduces the number of required OSPF adjacencies by becoming adjacent with all the other
routers on the network segment. Some networks also have a Backup Designated Router (BDR),
which takes over DR duties if the DR fails.

Basic OSPF Configuration for Router R1
router ospf 1
network 1.1.1.1 0.0.0.0 area 0
network 10.1.1.0 0.0.0.255 area 0
network 10.1.2.0 0.0.0.255 area 0
neighbor 10.1.1.2

Basic OSPF Configuration for Router R2
interface Serial0/0
ip ospf priority 0
router ospf 1
network 2.2.2.2 0.0.0.0 area 0
network 10.1.1.0 0.0.0.255 area 0
network 172.16.1.0 0.0.0.255 area 1

Basic OSPF Configuration for Router R3
router ospf 1
network 3.3.3.3 0.0.0.0 area 1
network 172.16.1.0 0.0.0.255 area 1
network 192.168.1.0 0.0.0.255 area 2

Basic OSPF Configuration for Router R4
router ospf 1
network 4.4.4.4 0.0.0.0 area 2
network 192.168.1.0 0.0.0.255 area 2

Step 2: Configure OSPF Virtual Links

After the initial OSPF configuration, this lab shows that router R4 has learned no routes via OSPF.
The underlying issue is that in this lab’s topology, area 2 is not adjacent to area 0, and OSPF has a
requirement that all areas must be adjacent to area 0 (that is, the backbone area) in a multiple-area
OSPF network.

An OSPF virtual link can fix this issue by virtually linking an area to area 0. This virtual link
crosses another area, which you can think of as a transit area. To configure a virtual link across
this transit area, two routers must be configured for the virtual link.
One of the two routers is an area border router (ABR) that connects the transit area to area 0. The
other router that must be configured for the virtual link is an ABR that connects to both the transit
area and the area not adjacent to area 0.

Configuring a Virtual Link on R2
router ospf 1
area 1 virtual-link 3.3.3.3

Configuring a Virtual Link on R3

router ospf 1
area 1 virtual-link 2.2.2.2

Configuring EIGRP

The objectives of the lab are as follows:
■ Configuring basic EIGRP
■ Disabling autosummarization
■ Load-balancing across unequal paths
■ Configuring a default route
■ Verifying EIGRP configuration


Step 1: Configure and Verify Basic EIGRP Connectivity—Initial  Configurations

Initial Configuration for R1

hostname R1
interface FastEthernet0/0
ip address 10.1.1.1 255.255.255.0
duplex auto
speed auto
!
interface Serial0/0
bandwidth 2000
ip address 192.168.11.1 255.255.255.0
encapsulation ppp
!
interface FastEthernet0/1
ip address 192.168.1.1 255.255.255.0
duplex auto
speed 10

Initial Configuration for R2
hostname R2
!
interface Ethernet0
ip address 192.168.1.2 255.255.255.0
!
interface Serial0
bandwidth 2000
ip address 192.168.11.2 255.255.255.0
encapsulation ppp
clock rate 2000000
!
interface Serial1
ip address 192.168.2.2 255.255.255.0
encapsulation ppp
clock rate 2000000


Initial Configuration for R3hostname R3
!
interface Ethernet0
ip address 10.1.2.3 255.255.255.0
!
interface Serial0
bandwidth 2000
ip address 192.168.2.3 255.255.255.0
encapsulation ppp

Step 1: Configure and Verify Basic EIGRP Connectivity—Ending Configurations


Basic EIGRP Configuration for R1
router eigrp 1
network 10.1.1.0 0.0.0.255
network 192.168.1.0
network 192.168.11.0

Basic EIGRP Configuration for R2
router eigrp 1
network 192.168.1.0
network 192.168.2.0
network 192.168.11.0

Basic EIGRP Configuration for R3
router eigrp 1
network 10.1.2.0 0.0.0.255
network 192.168.2.0

Step 2: Disable Autosummarization


After the initial EIGRP configuration, the lab shows that, by default, EIGRP advertises networks at
their classful boundary. Specifically, in this lab, the 10.1.1.0/24 network on router R1 and the
10.1.2.0/24 network on router R3 are both advertised to router R2 as network 10.0.0.0/8. This is
because a Class A IP address has an 8-bit classful subnet mask.

Therefore, given the Ethernet link’s more favorable EIGRP metric router, R2 always uses the
Ethernet connection to R1 when trying to send packets to the 10.0.0.0/8 network. As a result, network
10.1.2.0/24 becomes unreachable from routers R1 and R2.

To overcome this default behavior, and to advertise a network’s subnet mask along with the network
addresses, this lab disables EIGRP’s autosummarization behavior on all routers in the topology.

Disabling Autosummarization on R1
router eigrp 1
no auto-summary

Disabling Autosummarization on R2

router eigrp 1
no auto-summary

Disabling Autosummarization on R3

router eigrp 1
no auto-summary

Step 3: Load-Balance Across Unequal-Cost Paths
One link is a serial interface running at 2 Mbps, and the other link is a 10-Mbps Ethernet interface. By default, EIGRP uses the link withthe most attractive metric, which, by default, is based on bandwidth and delay. Therefore, as traffic passes between routers R1 and R2, the serial link is not used.

To increase throughput between those routers, you should enable EIGRP’s variance feature. The
variance feature allows EIGRP to load-balance across unequal-cost paths. However, the cost (that
is, the metric) must vary by no more than a specific factor, as specified by the variance command.
This lab uses a variance of 10. The variance parameter is a multiplier applied to the best metric to
create a range of metrics. EIGRP then load-balances across all available paths that have metrics in
that range.
Configuring the Variance Feature on R1
router eigrp 1
variance 10

Configuring the Variance Feature on R2
router eigrp 1
variance 10

Step 4: Advertise a Default Route

 When end-to-end connectivity is established in the lab topology and all links are used, because of
the variance configuration, this lab discusses how to point the routers to a default route. The
default route is statically configured to point out the Ethernet 0 interface of router R3. This static
route is then advertised via EIGRP to routers R1 and R2.

Configuring a Static Default Route on R3
ip route 0.0.0.0 0.0.0.0 Ethernet0

Advertising a Static Default Route on R3 
router eigrp 1
network 0.0.0.0




9.12.2011

Final Configuration of Basic configuration CISCO Route

Giving a description of the interface is very important to help users of information relating to the interface, especially for large-scale networks is very important provision of this description.
Description will also appear in the configuration file, although giving a description will not give any influence to the system.

To configure an interface description, enter global config. Then go into interface config by using a command like the following description:
- Use the configure terminal command to enter global config- Enter the interface to be configured, eg interface ethernet 0- Enter a description, for example, XYZ Network, Building 18- Use Ctrl-Z to exit interface config and return to privileged EXEC mode- Use the command copy running-config startup-config command to save configuration changes to NVRAMHere is an example of interface descriptions:
interface ethernet 0description Engineering LAN, Bldg.2interface serial 0description ABC network 1, Circuit 1
Login bannerIs the message that appears at login. Login banners can be used to convey a message to all users. For example a message "Welcome" as a welcome message for users who log into the router.
Configuring message-of-the-day (MOTD)Enter global config to configure the MOTD banner. Use the banner motd command, followed by a space and the separator character such as a pound sign (#). As the example below:- Use the configure terminal command to enter global config- Enter the command banner motd # #- Perform the command copy running-config startup-config command to save the changes Image

Host name resolutionIs the process by which computer systems use a hostname with an IP address. To use the hostname of communication with other IP devices, networking equipment like routers have IP addresses and associated with. Cisco IOS maintains a cache mapping from name to address with the command EXEC. The speed of the cache affects the speed of the conversion of names to addresses.Hostname here is different from the DNS, where hostname is the name of the router.
Configure hostname tableTo configure the hostname table, first enter global config command ip host followed by the destination IP address. To test connectivity to the host using telnet or ping command followed by the IP address of the destination. The procedure to configure the host table as follows:- Go to the config global- Enter the command ip host followed by the name of the router or the destination router's IP address- Repeat above steps until all the routers can be called- Save configuration to NVRAM
Backup configuration filesConfiguration should be stored and backed up for later if there are problems with the system. Configurations can be stored on a network server (TFTP server) or a disk stored safely somewhere.To save a configuration that is the path to the TFTP server use the command copy running-config tftp, such as the following steps- Type the command copy running-config tftp- Enter the IP address of the TFTP server- Enter the name of the configuration file- Answer yes to confirmationConfiguration file stored on a network server can be used to configure the router. To do so in the following way:- Use the command copy tftp running-config- Select the configuration file that would put into the router. Then enter the IP address of the remote host where TFTP server is located- Enter the name of the configuration file or use the default name. The default name is hostname-config file for host and network-config to the network configuration file. Example file name: router.cfgTo save the configuration to disk, by means of capture and store the text on the router.

Basic Configuration of Cisco Router

All CLI configuration will change the router to global configuration or global config. Config global configuration mode is most important. Global config is used in routers to execute configuration commands. The prompt shown in the global config mode:
Router # configure terminalRouter (config) # 
Below are a few modes that can go into global config mode:- Interface mode- Line mode- Router mode- Subinterface mode- Controller modeType exit from one of the above modes will return to global config mode. Emphasis Ctrl-Z will return to privileged EXEC mode.
Configuring a router name
 
A router should have a unique name. Giving a name is the first step on the router configuration.Router (config) # hostname TokyoTokyo (config) #When pressed Enter, the prompt will change from the default hostname to Tokyo.


Configuration passwordPasswords should always be configured for virtual terminal (vty) and the console terminal. Password is also useful for controlling access to privileged EXEC mode so that only certain people are just biased change the router settings.The command below is used to setup a password on the console terminal:Router (config) # line console 0Router (config-line) # loginRouter (config-line) # password
Passwords should be set at one or more terminals to provide the right health insurance VTY users connect via telnet. Cisco routers generally have a terminal vty 0 through 4. Some other types may have different number of VTY terminals. The following commands are used for setting passwords on vty terminal:Router (config) # line vty 0 4Router (config-line) # loginRouter (config-line) # password
Commands enable password and enable secret is used to enter privileged EXEC mode. Enable password command is used only if it is because the enable secret password is encrypted. While the enable password is not encrypted. Below is the command used to setup a password:Router (config) # enable password
Router (config) # enable secret
Sometimes it is not safe if left in a state of clear text passwords on the console terminal screen from the command show running-config or show startup-config. To avoid this use a command like the following:Router (config) # service password-encryptionThe above command will give the appearance of the password is encrypted. Enable secret command uses MD5 algorithm for encryption.

These commands show- Show interfaces - to display the statistics of all router interfaces. To display the specific interface statistics, use the show interfaces command followed by the port number / slot interface such as the command below.Router # show interfaces serial 0 / 1- Show controllers serial - Displays information specific hardware interface. This command must be set, including the port number / slot of the serial interface. Example:Router # show controllers serial 0 / 1- Show clock - displays the time on the router.- Show hosts - manmapilkan cached list of host names and addresses.- Show users - manmpilkan all users who connect to the router.- Show history - shows history of commands that have been done.- Show flash - Displays information about flash memory and what IOS files are stored there.- Show version - displays information about the software version that is now under way complete with hardware and device information.- Show arp - Displays the ARP table of the router.- Show protocols - the interface displays the status of both global and khusu of layer 3 protocols are configured.- Show startup-config - displays the contents of the configuration file stored in NVRAM- Show running-config - displays the contents of the configuration file is the path or configuration of the interface or class map information. 

Configure serial interfaceThe steps to configure the serial interface is:- Go to global configuration mode- Sign in interface mode- Specifies an interface address and subnet masknya- Setting clock rate if a DCE cable connected. No need to clock rate settings if connected to the DTE cable- Turn on the interfaceEach serial interface must have an IP address and subnet mask for routing IP packets. Configuring the IP address as follows:Router (config) # interface serial 0 / 0Router (config-if) # ip address
Serial interfaces require a clock signal to control the timing of the communication. Generally DCE equipment such as CSU / DSU to clock it. By default, Cisco routers are DTE devices but the bias is configured as DCE equipment.On a serial link that is directly connected, such as the configuration in the Lab, one side must be set as a DCE and must be set clocknya signal. For setting the clock and speed by using the clock rate command. Clock rate provided in bits per second is 1200, 2400, 9600, 19200.38400, 56000th, 64000th, 72000th, 125000, 148000, 500000, 800000, 1 million, 1.3 million, 2 million, or 4 million. Setting depends on the capacity of the interface.By default the interface is in the off state or disabled. To enable it or enable it using the command no shutdown. If you want to restore to the state off again just entered the shutdown command.In the lab, the clock rate is usually set to 56 000. commands used for setting the clock rate as follows:
Router (config) # interface serial 0 / 0Router (config-if) # clock rate 56000Router (config-if) # no shutdown

Perform configuration changesBefore making changes, normally previewing configuration that is the way to the show running-config command. If the variable that is displayed is not correct, to fix the following way:- Use no in front of the command- Restore the initial configuration file from NVRAM- Copy the configuration file from the TFTP server- Remove the startup configuration file with the command erase startup-config, then restart and go into setup modeTo save the configuration to the startup configuration file in NVRAM, enter the privileged EXEC mode. As the command below.Router # copy running-config startup-config
Configure ethernet interfaceEach Ethernet interface must have an IP address and subnet mask for routing IP packets.To configure the Ethernet interface in the following way:- Go to the config global- Go to the config interface- Specify the interface address and subnet mask- Enable interfaceBy default, Ethernet interfaces in the off state or disabled. To on the command no shutdown. If you want to back off with the shutdown command.

9.11.2011

The introduction of cisco IOS

Router or switch will not work without operating system. Without operating system, hardware will be useless. Cisco IOS has the ability to:
- Basic routing and switching functions- Access to the secured network keamannya- Operates at the network scale
CLI can be accessed in several ways. In general, the CLI is accessed through a console terminal. Console using low-speed serial connection that plugs directly from the router to the PC. CLI can also be accessed via a remote connection via dialup modem to the router AUX port. The third way is via telnet to the router. To access via telnet, at least one router interface is configured network address (IP address), and virtual terminal must be configured for the login and password.
CLI on a cisco has a hierarchical structure. This structure is useful for other types of commands to the router. Example, to configure a router interface, the user must enter the configuration mode. All configuration is inserted into the interface was only valid for a configurable inetrface only. IOS provide interpreter service known as the command executive (EXEC). After each command entered, the EXEC will validate and execute commands.
Cisco IOS is divided into two levels of access, the user EXEC mode and privileged EXEC mode. Privileged EXEC mode is also known as enable mode. Below are the features of the user EXEC mode and privileged EXEC mode:
- User EXEC mode commands are only limited. Usually includes only the commands that are monitoring or view.User EXEC does not allow users to make configuration changes on the router. User EXEC mode is characterized by prompt>- Privileged EXEC mode contains a command = command for access to the router. This mode can be used to configure the password. And usually this mode is often used by administrators to commands that are configuration and management. Global configuration mode and other configuration modes can only be done through this mode. Privileged EXEC mode prompt is marked with # 

For access to privileged EXEC mode level, a user who is a user-level EXEC must type enable at the command prompt>, if the password is entered correctly then the prompt will change to #. This suggests that the current user is in privileged EXEC level. At the time the command inserted?, It will show what commands are allowed to do at the time. 
At startup, Cisco is normally called the RAM and run one of the three modes. System administrators can use the configuration register to set the default startup settings.ROM monitor is used to bootstrap the process and provide a low-level functions and for purposes of diagnosis. This mode is used to restore a system failure (system failures) and returns the password. This mode is not accessible via the network interface, and can only be accessed via a physical connection via the console port. 
At the router the way in ROM mode, only a few features of IOS can walk. Boot ROM allows storage operations to the flash memory and used to replace the Cisco IOS image stored in flash. Cisco IOS can be modified in the boot ROM with the command copy tftp flash. This command to copy the IOS image in the TFTP server to the router's flash memory. 
Normally the router using the full Cisco IOS image stored in flash. Some devices, IOS run directly from flash. However, most Cisco routers require a copy of the IOS to the RAM and run from RAM. Some of the IOS image stored in flash in a compressed state and must be extracted when copied into RAM.To find the IOS image and version being used road show version command. Show flash command is used to verify the memory required to load a new Cisco IOS image.

9.10.2011

Connect Personal Computer to The Router

The first time the router is used, no network is configured, so the router can not communicate with other networks. To set up the router to connect to the network, then the necessary initialization and configuration. It is necessary to roll-over cable is connected between the management port to the computer via a terminal emulating software like hyperterminal. After configuration, the router is ready for communication with the network.

Below, the steps to connect the PC to the router:
1. Configuration to a PC with terminal emulation parameters:
- COM port that is used
- Baud: 9600
- Data bits: 8
- No parity
- Stop bits 1
- No flow control
 
2. Connect the RJ-45 roll-over cable to the router console terminal
3. Connect the other end to the DB-9 terminal
4. Connect the female DB-9 terminal adapter to the PC
 


Interface connection to the LAN router
Routers are generally connected to the LAN via Ethernet or Fast Ethernet interface. Router as a host that communicates with the LAN through a HUB or Switch. In this case the straight-through cables are used. For 10BASE-TX or 100BASE-TX requires Category 5 UTP cable or better.

Wide Area Network (WAN)

WAN is a data communications network at a large geographic area like a province or country. WAN always uses transmission facilities provided by telecommunications companies such as telephone service company.

Characteristics of WAN:
- Connect the equipment is spread over a wide geographic area
- Using public service channels, such as telecommunications companies to form a network in the role in the  
   geographic area.
- Using a serial connection to access the bandwidth across the geographic area.

A WAN operates at the physical layer and data link layer of the OSI layer. WAN connecting over a LAN within a broad geographic area.

The equipment used dalan WAN:
- Router, including internetworking and WAN interface ports.
- Modem, including voice-grade interfaces, channel service units / digital service units (CSU / DSU) 
   that serve the T1/E1 interface, and the Terminal Adapter / Network Termination 1 (TA / NT 1) as an      
   interface Integrated Services Digital Network (ISDN) .
- Server-server dial-in and user-user to dial out to connect. 


WAN is made for:
- Operating on a very wide geographic area
- Able to provide a serial connection with low cost and low-speed or cost of such expensive and high-speed 
  ATM or via the fiber optic
- Able to provide full-time connection and part-time. 


The introduction of WAN routers

Router is a special computer, a router has the basic components are the same as the desktop PC, the Router has a CPU, memory, system bus, and a lot of interface input / output. Routers are designed to perform specific tasks that are not owned by the PC desktop. For example, the router connects and allows communication between two networks and determines the data path through network connections.
Same with the PC, a router requires the operating system to perform its functions, the Internetwork Operating System (IOS) software to run the configuration files. Configurations contain commands and parameters that control the flow of traffic in and out of the router. Routers use routing protocols to determine the best path.
The main components of the router is a random-access memory (RAM), nonvolatile random-access memory (NVRAM), flash memory, read-only memory (ROM) and interfaces.
RAM has the following characteristics and functions:
- Save the routing table
- Handle the ARP cache
- Dealing with fast-switching cache
- Dealing with packet buffering and shared RAM
- Handles packet queue
- Provides temporary memory for the router configuration file at work
- Data will be lost when the router is shut down or restart
NVRAM has the functions and characteristics as follows:
- Provides storage for the startup configuration file
- Data is still there even though the router is switched off or restarted
Flash memory has the following characteristics and functions:
- Handle IOS image
- Provides access to software to perform the update without having to remove the chip on the processor
- Data is still there when the router is shut down or restart
- Can store multiple versions of IOS software
- Is a type of electrically erasable programmable read-only memory (EEPROM)
ROM has the following characteristics and functions:
- Handle commands for power-on diagnostics selt test (POST)
- Stores the bootstrap program and basic operating system
- Requires remove the chip on the motherboard when upgrading software melaukan
Interface has the following characteristics and functions:
- Connecting to a network router as the entry and exit of data packets
- Just being in the motherboard or as a separate module 


The rules in the WAN Routers

Standar and the main functions of the protocol, or WAN are operating at the physical layer and data link layer. This means that five other layers are not found in the WAN. In other words satndar and protocol layer 1 and layer 2 of a WAN different from the standards and protocol layer 1 and layer 2 of the LAN.

WAN physical layer describes the interface between data terminal equipment (DTE) and data circuit-terminating equipment (DCE). Generally, the DCE is on the provider and the DTE is on the device. In this model, communication through the DTE with the help of a modem or CSU / DSU.

The main function of a router is to transmit data using Layer 3 addresses. This process is called routing. Routing occurs at the network layer, or Layer 3. If the WAN operates at Layer 1, 2 and 3, if the router is the equipment to a LAN or WAN? the answer is both.

Routers in a WAN is to deliver data packets on layer 3, but it can also be used in a LAN. At the time of the router using a standard protocol and physical layer and data link layer so it operates as WAN equipment. For example, a router mungkina must have an ISDN interface that uses PPP encapsulation and a serial interface that is connected to T1 lines using Frame Relay encapsulation. The router must be able to change the bit stream from one service type to another type, in this case to a T1 ISDN data link and change the encapsulation from PPP to Frame Relay.
Below is a list of physical layer standards and protocols on the WAN:
- EIA/TIA-232
- EIA/TIA-449
- V.24
- V.35
- X.21
- G.703
- EIA-530
- ISDN
- T1, T3, E1 and E3
- XDSL
- SONET (OC-3, OC-12, OC-48, OC-192)


Below is a list of standards and protocols on the WAN data link layer:

- High-level data link control (HDLC)
- Frame Relay
- Point-to-Point Protocol (PPP)
- Synchronous Data Link Control (SDLC)
- Serial Line Internet Protocol (SLIP)
- X.25
- ATM
- LAPB
- LAPD
- LAPF